Is Design Space glitchy for you too?

PSA: so after 55 minutes on live chat… and deleting everything I worked on the last to days… I was instructed to clear my cache. So far once I close something and reopen it everything is working. Also as you wait in chat it does tell you to open up DS on your tablet or phone for the new “update” is messing people up. Supposedly once you follow the instructions of the new update on you non pc device - your DS should work again okay on your PC… That’s what I got 1 hour ago… hope it helps. p.s. This update has been messing up for PC and Mac users just a FYI… its not being picky with who it mess’s with.

01:51:04 AM) Cricut: 2020 – New Machines Update: Thank you for continuing to hold. We are currently aware of some members experiencing issues using their new machines in the desktop application. If you are chatting in because of this issue, please try using the mobile app on your phone or tablet. Once you have set up the new machine via the mobile app, you will be able to use the desktop app like usual.

1 Like

@Leesa_M, thanks for the interesting information.

1 Like

I’ve had this happen only when using a downloaded and manually installed font that I leave in a custom folder. I use nexusFont to manage my fonts and sometimes when I install them I don’t choose “move to system folder”. When I’ve done this they won’t appear (as you describe in the original post) or the text field on the right side of design space will show a moving circle like its “thinking”.

The fix that works for me in this situation (I am using nexus font on a Windows PC):

  1. Uninstall the font
  2. Reinstall the font
  3. With my project open In Design Space, click the menu items:
    View and then Force Reload

Then I create a new text area in my project and select the font I reinstalled. Works like a charm.

I hope this helps someone else :grinning:

1 Like

@Yelsob, thanks for this information; I hope it helps someone. What I’m refering to, in my original post, though, is the text not showing up when I type it in, and it should show up in Cricut Sans (that is, I don’t select any font - DS should be displaying my text in the default font), and nothing shows up at all.

Sorry I was of no help :frowning_face:

I almost exclusively use system fonts and something similar to what you describe happens all the time with those. When a system font would not display, I would try selecting a Cricut font and most of the time the text would appear, however sometimes it wouldn’t.

A related issue I’ve experienced is editing text and the changes I make do not appear on screen. When this happened, if I edited the textarea again, I would see the changes I made but they would never appear on-screen (if that makes sense). Force reloading the app generally fixed this.

I know their support was of no help when I could not get even Cricut fonts to display. I learned to always try force reloading the app first and sometimes it would fix my issue and sometimes not. But I remember at least one time there was an issue where their app could not “talk to” their server. I just had to wait until they fixed the issue and then update my app.

As a disclaimer to my advice, I am a programmer/web developer so I tend to look at issues from a very technical perspective and most of the time app issues are caused by something not being up-to-date in the app or the app cannot communicate with the server. That is why force reload has become my go-to fix.

Please do let us know if you ever find a fix, I would love to make note of it for the future.

1 Like

But, @Yelsob, all the hints and tips we can share help all of us, since the problem I outlined in my original post, is not, by any means, the only problem I’ve encountered with DS, so thanks for your 2¢ :wink:

1 Like

I’ve been seeing the worst text and font glitches with the Desktop version of DS. Text won’t appear and scrolling through my personal fonts freezes the program altogether. I hope fixes are coming soon!

I’m on a MAC and have continued issues. I just updated a few days ago, so I’m hoping some of the bugs are fixed!

1 Like

Did you get the massive update a few days ago for the Mac IOS? Are you on Catalina? I had to restart my Macbook Pro yesterday to clear out funky stuff and it worked. Might want to do a full shut down and restart too.

1 Like

I did get the update. Will be using DS today,
so crossing my fingers that there are less glitches.

Hi,I’m new just got my cricut maker and I thought I could work with it using my tablet or phone but I see I cant do things I want like load fonts and images unless I’m doing it wrong would love some help if anyone has any time. Is there a certain kind of laptop or desktop I have to use? Thinking of getting one but cant get an expensive one please help. Thank you in advance